您的位置:首页 > 其它

hdu 2660 Accepted Necklace(01-背包变形 || DFS)

2014-07-27 10:57 453 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2660

Accepted Necklace

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2557 Accepted Submission(s): 1017

Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable
necklace my mother will accept.

Input
The first line of input is the number of cases.

For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.

Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.

The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.


Output
For each case, output the highest possible value of the necklace.

Sample Input
1
2 1
11
11
3


Sample Output
1


第一种、01-背包变形:

#include <cstdio>
#include <cstring>
int max(int x, int y)
{
	return x>y?x:y;
}
int dp[1017][21];
int main()
{
	int W,val[1017],wei[1017];
	int n, k, t, i, j, l;
	
	while(~scanf("%d",&t))
	{
		while(t--)
		{
			memset(dp,0,sizeof(dp));
			scanf("%d %d",&n,&k);
			for(i = 0 ;i < n; i++)
			{
				scanf("%d %d",&val[i],&wei[i]);
			}
			scanf("%d",&W);
			for(i = 0; i < n; i++)
			{
				for(l = W; l >= wei[i]; l--)
				{
					for(j = 1; j <= k; j++)
					{
						dp[l][j] = max(dp[l][j],dp[l-wei[i]][j-1]+val[i]);
					}
				}
			}
			printf("%d\n",dp[W][k]);
		}
	}
	return 0;
}


第二种、DFS:

#include <iostream>
#include <algorithm>
using namespace std;
struct st
{
	int v, w;
}a[1017];
int vis[1017];
int n, k, wei, MAX;
void dfs(int val,int weight,int place,int cont)
{
	if(cont > k || weight > wei)
		return;
	if(cont == k)
	{
		if(val > MAX)
			MAX = val;
		return ;
	}
	for(int i = place; i <= n; i++)
	{
		if(vis[i] == 0)
		{
			vis[i] = 1;
			dfs(val+a[i].v,weight+a[i].w,i,cont+1);
			vis[i] = 0;
		}
	}
}
int main()
{
	int t;
	int i, j;
	while(cin >> t)
	{
		while(t--)
		{
			memset(vis,0,sizeof(vis));
			cin>>n>>k;
			for(i = 1; i <= n; i++)
			{
				cin>>a[i].v>>a[i].w;
			}
			cin>>wei;
			MAX = -1;
			for(i = 1; i <= n; i++)
			{
				vis[i] = 1;
				dfs(a[i].v,a[i].w,i,1);
				vis[i] = 0;
			}
			cout<<MAX<<endl;
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: