您的位置:首页 > 其它

poj 2431 Expedition

2014-07-27 09:55 330 查看
Description
A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run
over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows
can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that
there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input
* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P
Output
* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10

Sample Output
2

练习优先队列

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct stop
{
int x,v;
}r[10005];
bool cmp(stop a,stop b)
{
return a.x<b.x;
}
int main()
{
int i,n,l,p;
while(cin>>n)
{
for(i=0;i<n;i++)
cin>>r[i].x>>r[i].v;
cin>>l>>p;
for(i=0;i<n;i++)
r[i].x=l-r[i].x;
r
.x=l,r[n++].v=0;
sort(r,r+n,cmp);//一定要排序,给加油站的顺序无序
priority_queue<int>q;//贪心,每次加最大的油量
int ans=0,pos=0,tank=p;
for(i=0;i<n;i++)
{
int d=r[i].x-pos;
while(tank-d<0)
{
if(q.empty())
{
cout<<-1<<endl;
return 0;
}
tank+=q.top();
q.pop();
ans++;
}
tank-=d;
pos=r[i].x;
q.push(r[i].v);
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: