您的位置:首页 > 其它

Constructing Roads+最小生成树模板题+hdu

2014-07-26 23:23 337 查看


Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13732 Accepted Submission(s): 5209



Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village
C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village
i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2


Sample Output

179解决方案:以及建好的路直接置0就可以了,其他的就不说了。code:
#include<iostream>
#include<cstdio>
#include<cstring>
#define MMAX 103
using namespace std;
int Map[MMAX][MMAX],d[MMAX],vis[MMAX];
int N;
int prime(){
int ans=0;
memset(vis,false,sizeof(vis));
vis[0]=true;
d[0]=0;
for(int i=1;i<N;i++)
d[i]=Map[0][i];
for(int i=0;i<N;i++){
int s,Min=10000000;
for(int j=0;j<N;j++){
if(!vis[j]&&Min>d[j])
s=j,Min=d[j];
}
vis[s]=true;
if(Min!=10000000)
ans+=Min;
else break;
for(int j=0;j<N;j++){
if(!vis[j]&&d[j]>Map[s][j]){
d[j]=Map[s][j];
}
}

}
cout<<ans<<endl;
return ans;

}
int main()
{
while(~scanf("%d",&N)){
for(int i=0;i<N;i++){
for(int j=0;j<N;j++){
scanf("%d",&Map[i][j]);
}
}
int Q;
scanf("%d",&Q);
for(int i=0;i<Q;i++){
int a,b;
scanf("%d%d",&a,&b);
Map[a-1][b-1]=0,Map[b-1][a-1]=0;
}
prime();
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: