您的位置:首页 > Web前端

791 Color the fence

2014-07-26 17:26 288 查看

Color the fence

时间限制:1000 ms | 内存限制:65535 KB
难度:2

描述

Tom has fallen in love with Mary. Now Tom wants to show his love and write a number on the fence opposite to

Mary’s house. Tom thinks that the larger the numbers is, the more chance to win Mary’s heart he has.

Unfortunately, Tom could only get V liters paint. He did the math and concluded that digit i requires ai liters paint.

Besides,Tom heard that Mary doesn’t like zero.That’s why Tom won’t use them in his number.

Help Tom find the maximum number he can write on the fence.

输入There are multiple test cases.

Each case the first line contains a nonnegative integer V(0≤V≤10^6).

The second line contains nine positive integers a1,a2,……,a9(1≤ai≤10^5).输出Printf the maximum number Tom can write on the fence. If he has too little paint for any digit, print -1.样例输入
55 4 3 2 1 2 3 4 529 11 1 12 5 8 9 10 6

样例输出
5555533


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
int v,i,m=1,min,max;
int a[10];
while(~scanf("%d",&v))
{
min=1;
for(i=1;i<=9;i++)
{
scanf("%d",&a[i]);
if(a[min]>=a[i]) min=i;
}
if(a[min]>v)
{
printf("-1\n");
continue;
}
max=v/a[min];
while(max)
{
for(i=9;i>=min;i--)
{
if(v-a[i]<0) continue;
if((v-a[i])/a[min]==max-1)
{
printf("%d",i);
v-=a[i];
max--;
break;
}
}
}
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: