您的位置:首页 > 其它

HDU1171 Big Event in HDU 【母函数】

2014-07-26 14:45 323 查看

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 22835    Accepted Submission(s): 8018

[align=left]Problem Description[/align]
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

 

[align=left]Output[/align]
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.

 

[align=left]Sample Input[/align]

2
10 1
20 1
3
10 1
20 2
30 1
-1

 

[align=left]Sample Output[/align]

20 10
40 40

bool类型防溢出。

#include <stdio.h>
#include <string.h>
#define maxn 250002

struct Node{
int v, m;
} arr[52];
bool c1[maxn], c2[maxn];

int main()
{
int n, temp, mid, i, id, sum, j, k, a, b;
while(scanf("%d", &n), n > 0){
for(id = sum = 0; id < n; ++id){
scanf("%d%d", &arr[id].v, &arr[id].m);
sum += arr[id].v * arr[id].m;
}
memset(c1, 0, sum * sizeof(c1[0]));
memset(c2, 0, sum * sizeof(c2[0]));
sum = arr[0].v * arr[0].m;
for(i = 0; i <= sum; i += arr[0].v)
c1[i] = 1;
for(i = 1; i < id; ++i){
temp = arr[i].v * arr[i].m;
for(j = 0; j <= sum; ++j)
for(k = 0; k <= temp; k += arr[i].v)
c2[k + j] += c1[j];
sum += temp;
for(k = 0; k <= sum; ++k){
c1[k] = c2[k]; c2[k] = 0;
}
}
mid = sum >> 1;
while(c1[mid] == false) --mid;
b = mid; a = sum - b;
printf("%d %d\n", a, b);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU1171