您的位置:首页 > 其它

Add ‘em hdoj2162

2014-07-26 08:42 162 查看
                         Add ‘em

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2608    Accepted Submission(s): 1939

Problem Description

Write a program to determine the summation of several sets of integers.

 

Input

The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set, n. The next n input lines
will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.

 

Output

A single line of output should be generated for each set of integers. The line should have format shown below.

 

Sample Input

4

-1

3

1

1

2

19

17

5

-645

952

-1488

-5456

-9342

-1

 

Sample Output

Sum of #1 is 4

Sum of #2 is 36

Sum of #3 is -15979

 

Source

2008 “Sunline Cup” National Invitational Contest - Warm Up

#include<cstdio>

#include<string.h>

#include<stdlib.h>

__int64 a[20000];

int main()

{

 memset(a,0,sizeof(a));

 int n,ca;

      ca=1;

     while(scanf("%d",&n)&&(n!=-1))

 {

    __int64 sum;

    int i;

    for(i=0,sum=0;i<n;i++)

        {

         scanf("%I64d",&a[i]);

         sum+=a[i];

        }

       printf("Sum of #%d is %I64d\n",ca,sum);

   ca++;

 }

 system("pause");

 return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: