您的位置:首页 > 其它

309 BOBSLEDDING

2014-07-26 08:03 260 查看


BOBSLEDDING

时间限制:1000 ms | 内存限制:65535 KB
难度:3

描述

Dr.Kong has entered a bobsled competition because he hopes his hefty weight will give his an advantage over the L meter course (2 <= L<= 1000). Dr.Kong will push off the starting
line at 1 meter per second, but his speed can change while he rides along the course. Near the middle of every meter Bessie travels, he can change his speed either by using gravity to accelerate by one meter per second or by braking to stay at the same speed
or decrease his speed by one meter per second.

Naturally, Dr.Kong must negotiate N (1 <= N <= 500) turns on the way down the hill. Turn i is located T_i meters from the course start (1 <= T_i <= L-1), and he must be enter
the corner meter at a peed of at most S_i meters per second (1 <= S_i <= 1000). Dr.Kong can cross the finish line at any speed he likes.

Help Dr.Kong learn the fastest speed he can attain without exceeding the speed limits on the turns.

Consider this course with the meter markers as integers and the turn speed limits in brackets (e.g., '[3]'):

0 1 2 3 4 5 6 7[3] 8 9 10 11[1] 12 13[8] 14

(Start) |------------------------------------------------------------------------| (Finish)

Below is a chart of Dr.Kong 's speeds at the beginning of each meter length of the course:

Max: [3] [1] [8]

Mtrs: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14

Spd: 1 2 3 4 5 5 4 3 4 3 2 1 2 3 4

His maximum speed was 5 near the beginning of meter 4.

输入There are multi test cases,your program should be terminated by EOF

Line 1: Two space-separated integers: L and N

Lines 2..N+1: Line i+1 describes turn i with two space-separated integers: T_i and S_i
输出Line 1: A single integer, representing the maximum speed which Dr.Kong can attain between the start and the finish line, inclusive.
样例输入
14 3
7 3
11 1
13 8


样例输出
5


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct ts
{
int t,s;
}a[505];

int cmp(struct ts x, struct ts y)
{
return x.t<y.t;
}

int main()
{
int l,n,i,j,v,max;
int spd[1005];
while(~scanf("%d%d",&l,&n))
{
v=1;
for(i=0;i<n;i++)
scanf("%d%d",&a[i].t,&a[i].s);
sort(a,a+n,cmp);

for(i=j=0;i<n;i++)
{
while(j!=a[i].t)
spd[j++]=v++;
if(v>a[i].s)
{
v=spd[j]=a[i].s;
for(int k=j;;k--)
{
spd[k]=v++;
if(spd[k]==spd[k-1] || spd[k]==spd[k-1]-1)
break;
}
v=a[i].s;
}
}
while(j!=l) spd[j++]=v++;
spd[j]=v;
max=1;
for(i=0;i<=l;i++)
if(spd[i]>max)
max=spd[i];
printf("%d\n",max);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: