您的位置:首页 > 产品设计 > UI/UE

HDOJ 题目1005 Number Sequence(剩余定理)

2014-07-25 19:49 344 查看

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 102262    Accepted Submission(s): 24702


[align=left]Problem Description[/align]
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

[align=left]Output[/align]
For each test case, print the value of f(n) on a single line.

 

[align=left]Sample Input[/align]

1 1 3
1 2 10
0 0 0

 

[align=left]Sample Output[/align]

2
5

 

[align=left]Author[/align]
CHEN, Shunbao
 

[align=left]Source[/align]
ZJCPC2004

http://acm.hdu.edu.cn/showproblem.php?pid=1005
每49次循环一次,被坑
ac代码
#include<stdio.h>
int f[10000];
int main()
{
int a,b,n;
while(scanf("%d%d%d",&a,&b,&n)!=EOF&&a||b||n)
{
int i,tc,k=3;
f[1]=1,f[2]=1;
for(i=3;i<=49;i++)
{
f[i]=(a*f[i-1]%7+b*f[i-2]%7)%7;
}
printf("%d\n",f[n%49]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: