您的位置:首页 > 其它

POJ-Power Strings(next数组应用)

2014-07-25 18:28 232 查看

Power Strings


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation
by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).



输入

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A
line containing a period follows the last test case.

输出

For each s you should print the largest n such that s = a^n for some string a.

示例输入

abcd
aaaa
ababab
.


示例输出

1
4
3


提示

This problem has huge input, use scanf instead of cin to avoid time limit exceed.



给定一个字符串,问最多是多少个相同子串不重叠连接构成。

KMP的next数组应用。这里主要是如何判断是否有这样的子串,和子串的个数。

若为abababa,显然除其本身外,没有子串满足条件。而分析其next数组,next[7] = 5,next[5] = 3,next[3] = 1,即str[2..7]可由ba子串连接构成,那怎么否定这样的情况呢?很简单,若该子串满足条件,则len%sublen必为0(7%(7-5)!=0,所以不满足)。sunlen可由上面的分析得到为len-next[len]。

因为子串是首尾相接,len/sublen即为substr的个数。

若L%(L-next[L])==0,n = L/(L-next[L]),else n = 1

#include <iostream>
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <cctype>
#include <cmath>
#include <string>
using  namespace std;
char t[1000002];
int next[1000002];
void get_next(char *t,int *next)
{
  int i=0,j=-1,len=strlen(t);
  next[0]=-1;
  while(i<len)
  {
    if(j==-1||t[i]==t[j])
    {
      ++i;++j;
      if(t[i]!=t[j])
        next[i]=j;
      else
        next[i]=next[j];
    }
    else
    j=next[j];
  }
}
int main()
{
  //ios::sync_with_stdio(false);
  while(scanf("%s",t)!=EOF)
  {
    int len=strlen(t);
    if(t[0]=='.') break;
    get_next(t,next);
    if(len%(len-next[len])==0)
      printf("%d\n",len/(len-next[len]));
    else
    printf("1\n");
  }
  return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: