您的位置:首页 > 其它

HDU 2001 计算两点间的距离

2014-07-25 16:13 381 查看


计算两点间的距离

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 94857 Accepted Submission(s): 36409



Problem Description

输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

Input

输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。

Output

对于每组输入数据,输出一行,结果保留两位小数。

Sample Input

0 0 0 1
0 1 1 0


Sample Output

1.00
1.41


Author

lcy

Source

C语言程序设计练习(一)

Recommend

JGShining | We have carefully selected several similar problems for you: 1235 1406 1201 1229 1040

Statistic | Submit | Discuss | Note

#include <iostream>
#include <cmath>
#include <stdio.h>
using namespace std;
int main()
{
float n,a,b,c,d;
while (cin>>a>>b>>c>>d)
{
n=sqrt((a-c)*(a-c)+(b-d)*(b-d));
printf("%.2lf\n",n);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: