您的位置:首页 > 其它

(简单BFS)Knight Moves

2014-07-25 15:56 260 查看


Knight Moves


Time Limit : 2000/1000ms (Java/Other) Memory Limit : 131072/65536K (Java/Other)


Total Submission(s) : 50 Accepted Submission(s) : 30


Problem Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of
the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6


Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


Source

PKU

题目大意: 在8*8的棋盘内, 问骑士从一点到另一点至少需多少步.
分析:简单BFS
#include<iostream>
#include<map>
#include<string>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 10
bool vis[maxn][maxn];
int dx[8] = { 2, 2, -2, -2, -1, 1, -1, 1 }, dy[8] = { -1, 1, -1, 1, -2, -2, 2, 2 };
int bx, by, ex, ey;
struct Node
{
int x, y;
int step;
}tmp, u;
void BFS()
{
queue<struct Node> Q;
tmp.x = bx;	tmp.y = by;	tmp.step = 0;
if (tmp.x == ex&&tmp.y == ey)
{
printf("To get from %c%d to %c%d takes %d knight moves.\n", bx - 1 + 'a', by, ex - 1 + 'a', ey, tmp.step);
return;
}
vis[tmp.x][tmp.y] = true;
Q.push(tmp);
while (!Q.empty())
{
u = Q.front();	Q.pop();
for (int i = 0; i < 8; i++)
{
tmp.x = u.x + dx[i];	tmp.y = u.y + dy[i];	tmp.step = u.step + 1;
if (1 <= tmp.x&&tmp.x <= 8 && 1 <= tmp.y&&tmp.y <= 8)
if (vis[tmp.x][tmp.y] == 0)
{
if (tmp.x == ex&&tmp.y == ey)
{
printf("To get from %c%d to %c%d takes %d knight moves.\n", bx - 1 + 'a', by, ex - 1 + 'a', ey, tmp.step);
return;
}
vis[tmp.x][tmp.y] = true;
Q.push(tmp);
}
}
}
}
int main()
{
char ch1, ch2;
while (scanf("%c%d %c%d", &ch1, &by, &ch2, &ey) != EOF)
{
getchar();//用scanf()输入%c或%s时就要多留个心眼了,用gets()一般不易出错
bx = ch1 - 'a' + 1;	ex = ch2 - 'a' + 1;
memset(vis, false, sizeof(vis));
BFS();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: