您的位置:首页 > 其它

hdu 2070 斐波那契数列

2014-07-25 10:07 281 查看

/*Fibbonacci Number

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13421 Accepted Submission(s): 6685

Problem Description

Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0

f(1) = 1

f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.

Input

Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.

Output

Print out the answer in a single line for each test case.

Sample Input

3

4

5

-1

Sample Output

2

3

5

HintNote:

you can use 64bit integer: __int64

2014,07,25*/

#include<cstdio>

__int64 a[60];

int main()

{

int n,i;

a[0]=0;

a[1]=1;

for(i=2;i<60;i++)

a[i]=a[i-1]+a[i-2];

while(scanf("%d",&n)&&n!=-1)

{

printf("%I64d\n",a
);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: