您的位置:首页 > 其它

poj 2488

2014-07-24 22:41 190 查看
A Knight's Journey

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 30099Accepted: 10320
Description


Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source
TUD Programming Contest 2005, Darmstadt, Germany
AC代码:
#include<iostream>
#include<cstring>
using namespace std;
int p,q;
int G[30][30];
int sucess;
char ch[1000];
int a[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
int dfs(int x,int y,int step){
if(x<0 || x>p-1 || y<0 || y>q-1 || G[x][y]) return 0;
G[x][y]=1;
if(step==p*q){
ch[2*step]='\0';
return 1;
}
for(int k=0;k<8;k++){
if(dfs(x+a[k][0],y+a[k][1],step+1)){
ch[2*(step+1)-2]=y+a[k][1]+'A';
ch[2*(step+1)-1]=x+a[k][0]+'1';
return 1;
}
}
G[x][y]=0;
return 0;
}
int main(){
int T; cin>>T;
for(int cas=1;cas<=T;cas++){
cin>>p>>q;
for(int j=0;j<q;j++){
for(int i=0;i<p;i++){
sucess=0;
memset(G,0,sizeof(G));
ch[0]=j+'A';
ch[1]=i+'1';
if(dfs(i,j,1)){
sucess=1;
break;
}
}
if(sucess)
break;
}
cout<<"Scenario #"<<cas<<":"<<endl;
if(!sucess)
cout<<"impossible"<<endl<<endl;
else
cout<<ch<<endl<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: