您的位置:首页 > 其它

HDOJ 题目2899 Strange fuction(数学 导数)

2014-07-24 21:07 239 查看

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3079    Accepted Submission(s): 2278


[align=left]Problem Description[/align]
Now, here is a fuction:

  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)

Can you find the minimum value when x is between 0 and 100.
 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

[align=left]Output[/align]
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

[align=left]Sample Input[/align]

2
100
200

 

[align=left]Sample Output[/align]

-74.4291
-178.8534

 

[align=left]Author[/align]
Redow
 

题目链接:点击打开链接

基本思路

求函数的最小值,首先求导的导函数为:G(x) = 42 * x^6+48*x^5+21*x^2+10*x-y (0 <= x <=100)

分析导函数的,导函数为一个单调递增的函数。如果导函数的最大值小于0,那么原函数在区间内单调递减。

即F(100)最小;如果但函数的最小值大于0,那么原函数在区间内单调递增,即F(0)最小。如果导函数既有正又有负

又由于导函数是单增函数,所以必有先负后正,即原函数必有先减后增的性质。求出导函数的零点就是原函数的最小值点。

求导函数最小值方法是2分法

ac代码

#include<stdio.h>
#include<string.h>
#include<math.h>
double f(double x,double y)
{
return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double fc(double x,double y)
{
return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}
double max(double x,double y)
{
if(x>=y)
return x;
else
return y;
}
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
double x,y,left=0.0,right=100.0,a1,a2,a3,mid=50.0;
scanf("%lf",&y);
if(fc(0.0,y)>=0||fc(100.0,y)<=0)
printf("%.4lf\n",max(f(0.0,y),f(100.0,y)));
else
{
a1=fc(left,y);
a2=fc(right,y);
a3=fc(mid,y);
while(fabs(a1-a3)>0.0001)//由于是保留最后4位
{
if(a3<0)
{
left=mid;
a1=a3;
mid=(left+right)/2;
a3=fc(mid,y);
}
else
{
right=mid;
a2=a3;
mid=(left+right)/2;
a3=fc(mid,y);
}
}
printf("%.4lf\n",f(mid,y));
}
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: