您的位置:首页 > 其它

HDU2588GCD(欧拉函数)

2014-07-24 19:24 169 查看


GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 972    Accepted Submission(s): 437


Problem Description

The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.

(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:

Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

 

Input

The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

 

Output

For each test case,output the answer on a single line.

 

Sample Input

3
1 1
10 2
10000 72

 

Sample Output

1
6
260若X与n存在大于m的最大公约数,设d=(x,n);则X=q*d,n=p*d; 并且 (p,q)=1;我们可以枚举公约数,由欧拉函数的定义可知 phi(p)即为所求代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int phi(int n)
{
int rea=n;
for(int i=2;i*i<=n;i++){
if(n%i==0){
rea=rea/i*(i-1);
while(n%i==0)
n/=i;
}
}
if(n!=1)
rea=rea/n*(n-1);
return rea;
}

int main()
{
int cas,n,m;
cin>>cas;
while(cas--){
cin>>n>>m;
int ans=0;
for(int i=1;i*i<=n;i++){
if(n%i==0){//i或者n/i为公约数的情况
if(i>=m)//i为公约数 n/i为系数
ans+=phi(n/i);
if(i*i!=n&&n/i>=m)//i!=n/i时并且 n/i为公约数的情况
ans+=phi(i);
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: