您的位置:首页 > 其它

2014年多校联合赛第二场1011

2014-07-24 13:42 190 查看

ZCC Loves Codefires

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


[align=left]Problem Description[/align]

   Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".
It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan.
But why?
Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures.
After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible.
What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time.
Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the minimal score he will lose.(that is, the sum of Ki*Ti).

 

[align=left]Input[/align]

   The first line contains an integer N(1≤N≤10^5), the number of problem in the round.
The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem.
The last line contains N integers Ki(1≤Ki≤10^4), as was described.

 

[align=left]Output[/align]

   One integer L, the minimal score he will lose.

 

[align=left]Sample Input[/align]

3
10 10 20
1 2 3

 

[align=left]Sample Output[/align]

150

HintMemset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second.
L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150. 题意:做每道题都有时间和权值,总时间和杭电平时比赛做题时间统计一样。但是遇到一个比较奇葩的问题,数据类型不知道为什么不能用double,是能用long long!希望有大神看到给指点一下!AC代码:
#include<cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
struct A
{   int x,y;
double z;
};
int cmp(A a,A b)
{
return a.z<b.z;
}
A a[110000];
int main()
{
int n,i;
scanf("%d",&n);
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
scanf("%d",&a[i].x);
for(i=0;i<n;i++)
{
scanf("%d",&a[i].y);
a[i].z=a[i].x*1.0/a[i].y;
}
sort(a,a+n,cmp);
long long int num=0,sum=0;
for(i=0;i<n;i++)
{
num+=a[i].x;
sum+=num*a[i].y;
}
printf("%I64d\n",sum);
return 0;
}

错误代码:
<pre name="code" class="html">#include<cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
struct A
{
double x,y,z;
};
int cmp(A a,A b)
{
return a.z<b.z;
}
A a[110000];
int main()
{
int n,i;
scanf("%d",&n);
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
scanf("%lf",&a[i].x);
for(i=0;i<n;i++)
{
scanf("%lf",&a[i].y);
a[i].z=a[i].x/a[i].y;
}
sort(a,a+n,cmp);
double num=0,sum=0;
for(i=0;i<n;i++)
{
num+=a[i].x;
sum+=num*a[i].y;
}
printf("%.0lf\n",sum);
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: