您的位置:首页 > 其它

poj 1995 快速幂取模,核心是二分思想

2014-07-24 09:14 330 查看
熟能生巧,本体是模版题,运用二分思想,简化运算的时间

Raising Modulo Numbers

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4455 Accepted: 2559
Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment
was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players
including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be
divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.
Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 
(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input
3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output
2
13195
13

#include<stdio.h>
long long multi(long long a,long long b,long long m)//a^b%m
{
long long ans=1;
a%=m;
while(b)
{
if(b&1)
{
ans=(ans*a)%m;
b--;
}
b>>=1;
a=(a*a)%m;

}
return ans;
}

int main()
{
long long m,n,i,j,l,k,t;
scanf("%lld",&t);
for(i=0;i<t;i++)
{
long long s=0;
scanf("%lld%lld",&m,&n);
for(j=0;j<n;j++)
{
scanf("%lld%lld",&l,&k);
s+=multi(l,k,m);
s%=m;
}
printf("%lld\n",s);
}
return 0;
}
//二分思想都是把b/2!!

/*long long quick_mod(long long a,long long b,long long m)//a^b%m
{
long long ans=1;
a%=m;
while(b)
{
if(b&1)//如果b是奇数,二进制最后一位是1,作用判断是不是奇数
{
ans=(ans*a)%m;
b--;
}
b>>=1;//把b二分,b/2,化为二进制向右移一位,除以2;
a=(a*a)%m;

}
return ans;
}*/

/*long long multi(long long a,long long b,long long m)//a*b%m
{
long long ret=0;
while(b>0)
{
if(b&1)//如果b是奇数,二进制最后一位是1,作用判断是不是奇数
ret=(ret+a)%m;
b>>=1;//把b二分,b/2
a=(a<<1)%m;
}
return ret;
}*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: