您的位置:首页 > 其它

Monkey and Banana - HDU 1069 dp

2014-07-23 22:25 441 查看


Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7274 Accepted Submission(s): 3745



Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.



Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.



Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".



Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0




Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342




题意:给你n种类型的立方体,每种可以有无数个,然后将他们都堆起来,限制条件是上一个的底比下一个的底小一圈,问你最高能堆多高。

思路:先将立方体的6种方式存入,然后dp[i].h表示用i及其之前的立方体最高能堆多高,然后依次更新。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{ int x,y,h;
}dp[1010];
bool cmp(node a,node b)
{ return a.x*a.y>b.x*b.y;
}
int main()
{ int n,i,j,k,a,b,c,ans,temp,t=0;
  while(~scanf("%d",&n) && n)
  { ans=0;
    for(i=1;i<=n;i++)
    { scanf("%d%d%d",&a,&b,&c);
      dp[i*6-5].x=a;dp[i*6-5].y=b;dp[i*6-5].h=c;
      dp[i*6-4].x=a;dp[i*6-4].y=c;dp[i*6-4].h=b;
      dp[i*6-3].x=b;dp[i*6-3].y=a;dp[i*6-3].h=c;
      dp[i*6-2].x=b;dp[i*6-2].y=c;dp[i*6-2].h=a;
      dp[i*6-1].x=c;dp[i*6-1].y=a;dp[i*6-1].h=b;
      dp[i*6].x=c;dp[i*6].y=b;dp[i*6].h=a;
    }
    n*=6;
    sort(dp+1,dp+1+n,cmp);
    for(i=2;i<=n;i++)
    { temp=0;
      for(j=1;j<i;j++)
       if(dp[j].x>dp[i].x && dp[j].y>dp[i].y)
        temp=max(temp,dp[j].h);
      dp[i].h+=temp;
      ans=max(ans,dp[i].h);
    }
    printf("Case %d: maximum height = %d\n",++t,ans);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: