您的位置:首页 > 其它

poj2139 Six Degrees of Cowvin Bacon最短路问题

2014-07-23 20:09 288 查看
Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together
but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship
path exists between every pair of cows.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers
tell which cows were.

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input

4 2
3 1 2 3
2 3 4


Sample Output

100


Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

题意是有N只牛,有M个工作,同时做一个工作的分离度为1,如果一只奶牛参加两个工作a,b,分别在a,b中与ax,bx一起工作,则ax,与bx的分离度为2,这种关系可以递推。最后求出一只牛到其他所有的牛的平均距离的最小值。先把信息存到邻接矩阵中,用floyd即可求出求出。

#include<stdio.h>

#include<iostream>

#include<algorithm>

#include<vector>

#include<queue>

using namespace std;

#define MAX 1005

#define INF 1<<28

priority_queue<int,vector<int>,greater<int> >q;

int dp[MAX][MAX];

int main()

{

int n,m,i,j,k,a;

while(~scanf("%d%d",&n,&m))

{

for(i=1;i<=n;i++)

for(j=1;j<=n;j++)

{

dp[i][j]=INF;

}

for(k=1;k<=m;k++)

{

cin>>a;

int b[MAX];

for(i=1;i<=a;i++)

{

scanf("%d",&b[i]);

}

for(i=1;i<=a;i++)

{

for(j=i+1;j<=a;j++)

{

int x=b[i],y=b[j];

dp[x][y]=dp[y][x]=1;

}

}

}

for(k=1;k<=n;k++)

for(i=1;i<=n;i++)

for(j=1;j<=n;j++)

{

dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]);

}

for(i=1;i<=n;i++)

{

int sum=0;

for(j=1;j<=n;j++)

{

if(i==j) ;

else sum+=dp[i][j];

}

q.push(sum);//用队列找出一只牛到其他所有牛的距离只和的最小值。

}

int minsum=q.top()*100/(n-1);//不要写成int minsum=(q.top()/(n-1))*100;这样会WA,因为q.top()/(n-1)可能是小数。

printf("%d\n",minsum);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: