您的位置:首页 > 其它

HDU 1010 Tempter of the Bone ( dfs + 奇偶剪枝 )

2014-07-23 17:45 288 查看
D - Tempter of the Bone
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice HDU
1010

Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately
to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.



Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively.
The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.



Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.



Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0




Sample Output

NO
YES




题意:给一迷宫,给你起点和终点,问是否可以恰好在时间t时走出迷宫。

分析:上来一看题,大体上是简单的dfs,直接按普通的dfs写,一交肯定会TLE,因为没有剪枝。本题的关键在于如何剪枝,这是个技术活,开始也不怎么会,偶尔看到大神们的题解,原来是奇偶剪枝!!!很强大的剪枝。

这里借鉴一点网上大神的证明: 借鉴于
Zhongrongqing

奇偶剪枝:
是数据结构的搜索中,剪枝的一种特殊小技巧。
现假设起点为(sx,sy),终点为(ex,ey),给定t步恰好走到终点,
 

s
|
|
|
+e
如图所示(“|”竖走,“—”横走,“+”转弯),易证abs(ex-sx)+abs(ey-sy)为此问题类中任意情况下,起点到终点的最短步数,记做step,此处step1=8;
  

s
+
|+
|
+e
如图,为一般情况下非最短路径的任意走法举例,step2=14;
step2-step1=6,偏移路径为6,偶数(易证);
故,若t-[abs(ex-sx)+abs(ey-sy)]结果为非偶数(奇数),则无法在t步恰好到达;
返回,false;
反之亦反。

AC代码:

#include<iostream>
#include<cstring>
#define N 10

using namespace std;

int n,m,t,end_i,end_j;
bool visited

,flag,ans;
char map

;

int abs(int a,int b)
{
    if(a<b) return b-a;
    else return a-b;
}

void DFS(int i,int j,int c)
{
    if(flag) return ;
    if(c>t) return ;
    if(i<0||i>=n||j<0||j>=m) {return ;}
    if(map[i][j]=='D'&&c==t) {flag=ans=true; return ;}
    int temp=abs(i,end_i)+abs(j,end_j);
    temp=t-temp-c;
    if(temp&1) return ;//奇偶剪枝

    if(!visited[i-1][j]&&map[i-1][j]!='X')
    {
        visited[i-1][j]=true;
        DFS(i-1,j,c+1);
        visited[i-1][j]=false;
    }
    if(!visited[i+1][j]&&map[i+1][j]!='X')
    {
        visited[i+1][j]=true;
        DFS(i+1,j,c+1);
        visited[i+1][j]=false;
    }
    if(!visited[i][j-1]&&map[i][j-1]!='X')
    {
        visited[i][j-1]=true;
        DFS(i,j-1,c+1);
        visited[i][j-1]=false;
    }
    if(!visited[i][j+1]&&map[i][j+1]!='X')
    {
        visited[i][j+1]=true;
        DFS(i,j+1,c+1);
        visited[i][j+1]=false;
    }
}

int main()
{
    int i,j,x,y,k;
    while(cin>>m>>n>>t&&(m||n||t))
    {
        memset(visited,false,sizeof(visited));
        k=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                cin>>map[i][j];
                if(map[i][j]=='S')
                {
                    x=i;y=j;
                    visited[i][j]=true;
                }
                if(map[i][j]=='D')
                {
                    end_i=i;end_j=j;
                }
                if(map[i][j]=='X')k++;
            }
        }
        ans=flag=false;
        if(n*m-k-1>=t) DFS(x,y,0);
        if(ans) cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: