您的位置:首页 > 其它

hdu 2822 Dogs(BFS + 优先队列)

2014-07-22 23:13 281 查看

Dogs

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1909    Accepted Submission(s): 740


[align=left]Problem Description[/align]
Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim's), So he turn to you for
help to point out how could him dig as less as he could.

We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0)
aim at his friend's home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and
the up left corner is labeled as ( 1, 1 ).

 

[align=left]Input[/align]
The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with 'X' stands
for the lattices of house, and '.' stands for the empty land. The following two lines is the start and end places' coordinates, we guarantee that they are located at 'X'. There will be a blank line between every test case. The block where both two numbers
in the first line are equal to zero denotes the end of the input.
 

[align=left]Output[/align]
For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.
 

[align=left]Sample Input[/align]

6 6
..X...
XXX.X.
....X.
X.....
X.....
X.X...
3 5
6 3

0 0

 

[align=left]Sample Output[/align]

3
Hint
Hint: Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).

 

[align=left]Source[/align]
2009 Multi-University Training Contest 1 - Host by TJU

题意是给定起点和终点,在一个矩阵图,经过X没有花费,经过.花费1,求起点到终点的最小花费。

自己用普通的BFS没有写明白,参考了大神的优先队列。

代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
int x, y,step;
node(int _x=0,int _y=0,int _step=0):x(_x),y(_y),step(_step){};
friend bool operator< (node a, node b)
{
return a.step > b.step ;
}
};
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int n,m;
int sx,sy,ex,ey;
const int maxn=1005;
char mp[maxn][maxn];
int vis[maxn][maxn];
int ans;
int bfs()
{
priority_queue<node>q;
node now,next;
while(!q.empty())
q.pop();
q.push(node(sx,sy,0));
vis[sx][sy]=1;
while(!q.empty())
{
now=q.top();
q.pop();
if(now.x==ex&&now.y==ey)
return now.step;
for(int i=0;i<4;i++)
{
next.x=now.x+dir[i][0];
next.y=now.y+dir[i][1];
next.step=now.step;
if(next.x>=1&&next.x<=m&&next.y>=1&&next.y<=n&&!vis[next.x][next.y])
{
if(mp[next.x][next.y]=='.')
next.step=now.step+1;
vis[next.x][next.y]=1;
q.push(node(next.x,next.y,next.step));
}
}
}
return -1;
}
int main()
{
//freopen("in.txt","r",stdin);
while(scanf("%d %d",&m,&n)!=EOF)
{
if(m==0&&n==0)  break;
memset(vis,0,sizeof(vis));
for(int i=1;i<=m;i++)
scanf("%s",mp[i]+1);
scanf("%d %d %d %d",&sx,&sy,&ex,&ey);
ans=bfs();
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: