您的位置:首页 > 其它

HDU 4861 Couple doubi

2014-07-22 20:44 399 查看
题目链接:Couple doubi


Couple doubi

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 158 Accepted Submission(s): 132



Problem Description

DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i
(mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win
the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.

Input

Multiply Test Cases.

In the first line there are two Integers k and p(1<k,p<2^31).

Output

For each line, output an integer, as described above.

Sample Input

2 3
20 3


Sample Output

YES
NO


个人比较水,打表找了下规律,发现2的时候所有球都是1,3的时候是0 2 0 2 0 2 0 2···交替,5的时候是0 0 0 4 0 0 0 4 0 0 0 4···, 7 的时候是0 0 0 0 0 6 0 0 0 0 0 6·····,这样规律就出来了。

直接上代码:

#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
int k, p;
while(~scanf("%d%d", &k, &p))
{
if((k/(p-1))%2==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}


解题报告略叼:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: