您的位置:首页 > 其它

hdu 4861 Couple doubi

2014-07-22 19:57 225 查看
[align=left]Problem Description[/align]
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the
value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with
the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.

[align=left]Input[/align]
Multiply Test Cases.

In the first line there are two Integers k and p(1<k,p<2^31).

[align=left]Output[/align]
For each line, output an integer, as described above.

[align=left]Sample Input[/align]

2 3
20 3


[align=left]Sample Output[/align]

YES
NO一个公式
#include<cstdio>
#include<cstring>
int main()
{
int k,p;
while(~scanf("%d%d",&k,&p))
{
if((k/(p-1))%2)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: