您的位置:首页 > 其它

UVA 494 Kindergarten Counting Game

2014-07-22 00:50 357 查看
题目链接:UVA 494 Kindergarten Counting Game



Kindergarten Counting Game

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?


Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.


Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...



Sample Output

2
7
10
9

代码:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

int main()
{
char str[1010];
while(gets(str))
{
int len = strlen(str);
int ans = 0;
if(isalpha(str[0])) ans++;
for(int i = 1; i < len; i++)
if(isalpha(str[i]) && !isalpha(str[i-1]))
ans++;
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: