您的位置:首页 > 其它

Uva 401 Palindromes

2014-07-21 17:11 204 查看
A - Palindromes
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld
& %llu

Description

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string"ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right
as when the string is read from right to left.



A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string"3AIAE"
is a mirrored string because "A" and "I" are their own reverses, and"3" and"E" are each others' reverses.

A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string"ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the
original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string.

Of course,"A","T","O",
and"Y" are all their own reverses.

A list of all valid characters and their reverses is as follows.

CharacterReverseCharacterReverseCharacterReverse
AAMMYY
BNZ5
COO11
DP2S
E3Q3E
FR4
GS25Z
HHTT6
IIUU7
JLVV88
KWW9
LJXX
Note that O (zero) and 0 (the letter) are considered the same character and thereforeONLY the letter "0" is a valid character.

Input

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string
Note that the output line is to include the
-'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA


Sample Output

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.


Hint

use the C++'s class of string will be convenient, but not a must

题目解析:

给你一个字符串,这题主要是判断是否是回文,是否是镜像文。

镜像文按照文章所给个规律,判断。

如果是回文字符串则需要首尾相等,如果是镜像字符串则需要先将原字符串转化为回文再反向比较。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
using namespace std;
const int N = 36;
const char mir1
 = "ABCDEFGHIJKLMNOPQRSTUVWXYZ123456789";
const char mir2
 = "A   3  HIL JM O   2TUVWXY51SE Z  8 ";

bool palind(string str) {
	int len = str.size();
	for(int i=0;i<len/2;i++) {
		if(str[i] != str[len - i -1])
			return false;
	}
	return true;
}

string change(string str) {
	string tmp;
	int len = str.size();
	for(int i=0;i < len;i++) {
		for(int j=0;j<N;j++) {
			if(str[i] == mir1[j]) {
				tmp += mir2[j];
				break;
			}
		}
	}	
	char ch;
	for(int i=0;i<len/2;i++) {
		ch = tmp[i];
		tmp[i] = tmp[len - i -1];
		tmp[len - i -1] = ch;
	}	
	return tmp;
}

bool mirror(string str) {
	return str == change(str);
}

int main() {
	string str;
	bool flag1,flag2;
	while(cin >> str) {
		flag1 = palind(str);
		flag2 = mirror(str);
		if(!flag1 && !flag2) {
			cout<<str <<" -- is not a palindrome."<<endl;
		} else
			if(flag1 && !flag2) {
				cout<<str <<" -- is a regular palindrome."<<endl;
			} else
				if(!flag1 && flag2) {
					cout<<str <<" -- is a mirrored string."<<endl;
				} else
					if(flag2 && flag2) {
						cout<<str <<" -- is a mirrored palindrome."<<endl;
					}
		cout<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: