您的位置:首页 > 其它

Hdu 1058 — Humble Numbers

2014-07-21 15:51 453 查看
Many of you heard about ugly number. Now we are introducing a new number that is called bubble number.

A number whose only prime factors are 2,3,5 or 7 is called a bubble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 bubble numbers.

Write a program to find and print the nth element in this sequence.

Input Specification

The input consists of one or more test cases. Each test case consists of one integer n with

.
Input is terminated by a value of zero (0) for n.

Output Specification

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd",
"rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output. (here humble means bubble)
See http://en.wikipedia.org/wiki/English_numerals#Ordinal_numbers for more explanation of using correct suffix

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0


Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.


题意简单,每个数的素因子只能是2,3,5,7。写了几组数据稍作观察,发现每个数都能由它前面的数乘以2,3,5,7得到,只是顺序不同而已。
#include<stdio.h>
int f[6000];
int min;
int min_(int a,int b,int c,int d)
{
    min=a;
    if(min>c)
        min=c;
    if(min>b)
        min=b;
    if(min>d)
        min=d;
    return min;
}
int main()
{
    int n,a1=1,a2=1, a3=1,a4=1;
    f[1]=1;
    for(int i=2;i<6000;i++)
    {
        int b1=2*f[a1];
        int b2=3*f[a2];
        int b3=5*f[a3];
        int b4=7*f[a4];
        f[i]=min_(b1,b2,b3,b4);//实现每个数由其前面的数乘以2,3,5,7中任意一个得到。
        if(min==b1)
            a1++;
        if(min==b2)
            a2++;
        if(min==b3)
            a3++;
        if(min==b4)
            a4++;
    }//将humble数依次存入数组;
    while(scanf("%d",&n)&&n)
    {
        if(n%100==11)
            printf("The %dth humble number is %d.\n",n,f
);
        else if(n%100==12)
            printf("The %dth humble number is %d.\n",n,f
);
        else if(n%100==13)
            printf("The %dth humble number is %d.\n",n,f
);
        else if(n%10==1)
            printf("The %dst humble number is %d.\n",n,f
);
        else if(n%10==2)
            printf("The %dnd humble number is %d.\n",n,f
);
        else if(n%10==3)
            printf("The %drd humble number is %d.\n",n,f
);
        else
            printf("The %dth humble number is %d.\n",n,f
);
    }
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: