您的位置:首页 > 大数据 > 人工智能

poj 1273 -- Drainage Ditches

2014-07-21 09:07 274 查看
Drainage Ditches

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 55017Accepted: 20992
Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can
transport per minute but also the exact layout of the ditches, which
feed out of the pond and into each other and stream in a potentially
complex network.

Given all this information, determine the maximum rate at which
water can be transported out of the pond and into the stream. For any
given ditch, water flows in only one direction, but there might be a way
that water can flow in a circle.

Input

The input includes several cases.
For each case, the first line contains two space-separated integers, N
(0 <= N <= 200) and M (2 <= M <= 200). N is the number of
ditches that Farmer John has dug. M is the number of intersections
points for those ditches. Intersection 1 is the pond. Intersection point
M is the stream. Each of the following N lines contains three integers,
Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the
intersections between which this ditch flows. Water will flow through
this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the
maximum rate at which water will flow through the ditch.
Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.
Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

最大流的模板题。因为没有clear容器。贡献了好多次wr。。。悲剧。


/*======================================================================
*           Author :   kevin
*         Filename :   DrainageDitches.cpp
*       Creat time :   2014-07-20 17:26
*      Description :
========================================================================*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#define clr(a,b) memset(a,b,sizeof(a))
#define M 205
#define INF 0x7f7f7f7f
using namespace std;
struct Edge{
int from,to,cap,flow;
};
int supers,supert,n,m;
vector<Edge>edges;
vector<int>G[M];
bool vis[M];
int d[M],cur[M];

bool BFS()
{
clr(vis,0);
queue<int>Q;
Q.push(supers);
d[supers] = 0;
vis[supers] = 1;
while(!Q.empty()){
int x = Q.front(); Q.pop();
int len = G[x].size();
for(int i = 0; i < len; i++){
Edge& e = edges[G[x][i]];
if(!vis[e.to] && e.cap > e.flow){
vis[e.to] = 1;
d[e.to] = d[x]+1;
Q.push(e.to);
}
}
}
return vis[supert];
}
int DFS(int x,int a)
{
if(x == supert || a == 0) return a;
int flow = 0,f;
int len = G[x].size();
for(int& i = cur[x]; i < len; i++){
Edge& e = edges[G[x][i]];
if(d[x] + 1 == d[e.to] && (f = DFS(e.to,min(a,e.cap-e.flow))) > 0){
e.flow += f;
edges[G[x][i]^1].flow -= f;
flow += f;
a -= f;
if(!a) break;
}
}
return flow;
}
void AddEdge(int from,int to,int cap)
{
edges.push_back((Edge){from,to,cap,0});
edges.push_back((Edge){to,from,0,0});
int m = edges.size();
G[from].push_back(m-2);
G[to].push_back(m-1);
}
int Dinic(int s,int t)
{
int flow = 0;
while(BFS()){
clr(cur,0);
flow += DFS(s,INF);
}
return flow;
}
int main(int argc,char *argv[])
{
while(scanf("%d%d",&n,&m)!=EOF){
edges.clear();
for(int i = 0; i < M; i++){
G[i].clear();
}
supers = 1;
supert = m;
int u,v,c;
for(int i = 0; i < n; i++){
scanf("%d%d%d",&u,&v,&c);
AddEdge(u,v,c);
}
int ans = Dinic(supers,supert);
printf("%d\n",ans);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: