您的位置:首页 > 其它

1001. A+B Format (20)

2014-07-20 20:48 288 查看
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input
-1000000 9

Sample Output
-999,991
#include<stdio.h>
int main(){
int a, b, c;
while (scanf("%d%d\n", &a, &b) != EOF){
c = a + b;
if (c < 0){
printf("-");
c = -c;
}
if (c >= 1000000){
//输出得加上格式%03d,因为万一值不为3位数时即为两位时得补0。
printf("%d,%03d,%03d\n", c / 1000000, (c / 1000) % 1000, c % 1000);
}
else if (c >= 1000){
printf("%d,%03d\n", c / 1000, c % 1000);
}
else{
printf("%d\n", c);
}
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: