您的位置:首页 > 其它

Uva 10387 Billiard

2014-07-20 15:52 357 查看
C - Billiard
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld
& %llu
SubmitStatus

Description

In a billiard table with horizontal side a inches and vertical sideb inches, a ball is launched from the middle of the table. Afters > 0 seconds the ball returns to the point from
which it was launched, after having madem bounces off the vertical sides and
n bounces off the horizontal sides of the table. Find the launching angleA (measured from the horizontal), which will be between 0 and 90 degrees inclusive, and the initial velocity of the ball.

Assume that the collisions with a side are elastic (no energy loss), and thus the velocity component of the ball parallel to each side remains unchanged. Also, assume the ball has a radius of zero. Remember that, unlike pool tables, billiard tables have
no pockets.

Input

Input consists of a sequence of lines, each containing five nonnegative integers separated by whitespace. The five numbers are: a, b, s, m,
and n, respectively. All numbers are positive integers not greater than 10000.

Input is terminated by a line containing five zeroes.

Output

For each input line except the last, output a line containing two real numbers (accurate to two decimal places) separated by a single space. The first number is the measure of the angle A in degrees and the second is the velocity of the
ball measured in inches per second, according to the description above.

Sample Input

100 100 1 1 1
200 100 5 3 4
201 132 48 1900 156
0 0 0 0 0


Sample Output

45.00 141.42
33.69 144.22
3.09 7967.81


题目大意:

给你5个数字,分别是台球桌的长,台球桌的宽,台球运动的时间,台球碰到竖直面的次数,台球碰到水平面的次数。

注意:在碰撞的过程中能量不损耗。

求夹角和速度

题目解析:

就是根据长宽,时间和碰的次数,算出水平运动了多远,垂直运动了多久,再用三角函数求角度和速度。

#include <stdio.h>
#include <math.h>
const double PI = acos(-1.0);
int main() {
	double a,b,s,m,n;

	while(scanf("%lf%lf%lf%lf%lf",&a,&b,&s,&m,&n) != EOF && (a||b||s||m||n)) {

		double ang = atan( (n*b)/(m*a) ) * 180 /PI;
		double v = sqrt((a*m)*(a*m) + (b*n)*(b*n)) / s;
		
		printf("%.2lf %.2lf\n",ang,v);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: