您的位置:首页 > 其它

Corporative Network +uvalive+并查集

2014-07-19 20:33 316 查看
Corporative Network

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon,
for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A)
and one of the enterprises J in some cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I � J|(mod 1000). In such a way the two old clusters are joined in a new cluster,
served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace
of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input file will contains only the number T of the test cases. Each test will start with the number N of enterprises (5≤N≤20000).
Then some number of lines (no more than 200000) will follow with one of the commands:
E I � asking the length of the path from the enterprise I to its serving center in the moment;

I I J � informing that the serving center I is linked to the enterprise J.
The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each � the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output

0
2
3
5

解决方案:要在路径压缩的时候,更新节点到根的距离。

代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int pa[20010];
int dis[20010];
int N;
int fa(int x){
if(pa[x]!=x){
int root=fa(pa[x]);
dis[x]+=dis[pa[x]];///递归的过程中更新每个节点与根节点的距离
return pa[x]=root;
}///更新节点与根节点的距离,并路径压缩
else return x;
}
int main(){
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&N);
memset(dis,0,sizeof(dis));
for(int i=0;i<=N;i++){
pa[i]=i;
}
char op;
int u,v;
while(1)
{
cin>>op;
// cout<<op<<endl;
if(op=='E'){
scanf("%d",&u);
fa(u);
printf("%d\n",dis[u]);
}
else if(op=='I'){
scanf("%d%d",&u,&v);
dis[u]=int(abs(u-v))%1000;
pa[u]=v;
}
else if(op=='O') break;

}

}

return 0;}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: