您的位置:首页 > 产品设计 > UI/UE

(归并排序求逆序数) poj2299 Ultra-QuickSort

2014-07-18 19:58 405 查看
Ultra-QuickSort

Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 39686 Accepted: 14314
Description


In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is
sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence
element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0

Sample Output
6
0

Source

Waterloo local 2005.02.05

题意是给出一个大小为n的乱序数组,每次允许交换一对相邻的元素,问最少需几次交换能使数组升序排列。

交换数=数组的逆序数

本题我采用了归并排序的方法来做,其实还有线段树和树状数组等更加高效的做法。

结果会有大数,要用__int64

代码如下:

#include<stdio.h>

int seq[500005];
int n;
long long result;
const int inf=2000000000;

void compute(int l,int mid,int r){
int len1=mid-l+1;
int len2=r-mid;
int *s1=new int[len1+2];
int *s2=new int[len2+2];

for (int i=1;i<=len1;i++)
s1[i]=seq[l+i-1];
s1[len1+1]=inf;
for (int i=1;i<=len2;i++)
s2[i]=seq[mid+i];
s2[len2+1]=inf;

int i=1;
int j=1;
for (int k=l;k<=r;k++){
if (s1[i]<=s2[j]){
seq[k]=s1[i++];
}
else{
seq[k]=s2[j++];
result+=len1-i+1;
}
}
delete s1;
delete s2;
}

void mergesort(int l,int r){
if (l<r){
int mid=(l+r)/2;
mergesort(l,mid);
mergesort(mid+1,r);
compute(l,mid,r);
}
}

int main(){
while(scanf("%d",&n) && n){
for (int i=1;i<=n;i++)
scanf("%d",&seq[i]);

result=0;
mergesort(1,n);
printf("%lld\n",result);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: