您的位置:首页 > 其它

POJ 1014 Dividing dfs

2014-07-18 10:57 302 查看
Dividing

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 58553Accepted: 15071
Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in
half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the
same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot
be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1
2 0 0". The maximum total number of marbles will be 20000.

The last line of the input file will be "0 0 0 0 0 0"; do not process this line.
Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".

Output a blank line after each test case.
Sample Input
1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0

Sample Output
Collection #1:
Can't be divided.

Collection #2:
Can be divided.

Source

Mid-Central European Regional Contest 1999

大致题意:给你一些有价值的弹珠,这些弹珠的价值分为6种,即1,2,3,4,5,6,问你是否能分成两份,两份的弹珠价值总和要相等,价值总和为奇数时一定不可分,总和为偶数时dfs一下,额,背包的话想了半天没想出来。。。

#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <fstream>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <list>
#include <stdexcept>
#include <functional>
#include <utility>
#include <ctime>

using namespace std;

#define PB push_back
#define MP make_pair
#define REP(i,n) for(int i=0;i<(n);++i)
#define FOR(i,l,h) for(int i=(l);i<=(h);++i)
#define DWN(i,h,l) for(int i=(h);i>=(l);--i)
#define CLR(vis) memset(vis,0,sizeof(vis))
#define MST(vis,pos) memset(vis,pos,sizeof(vis))
#define MAX3(a,b,c) max(a,max(b,c))
#define MAX4(a,b,c,d) max(max(a,b),max(c,d))
#define MIN3(a,b,c) min(a,min(b,c))
#define MIN4(a,b,c,d) min(min(a,b),min(c,d))
#define PI acos(-1.0)
#define INF 0x7FFFFFFF
#define LINF 1000000000000000000LL
#define eps 1e-8

typedef long long ll;

const int maxn=22222;

int x[11];
int flag;
int sum,res;

void dfs(int ans,int n)
{
    if(flag) return;

    if(ans==res)
    {
        flag=1;
        return;
    }

    DWN(i,n,1)
    {
        if(x[i])
        {
            if(ans+i<=res)
           {
             ans+=i;
             x[i]--;
             dfs(ans,i);

             if(flag)
                break;
           }
        }
    }
    return;

}

int main()
{
    int cas=1;
    while(scanf("%d%d%d%d%d%d",&x[1],&x[2],&x[3],&x[4],&x[5],&x[6])!=EOF)
    {
        if(x[1]==0 && x[2]==0 && x[3]==0 && x[4]==0 && x[5]==0 && x[6]==0)
            break;
        printf("Collection #%d:\n",cas++);
        sum=x[1]+2*x[2]+3*x[3]+4*x[4]+5*x[5]+6*x[6];
        if(sum%2)
        {
            printf("Can't be divided.\n\n");
            continue;
        }

        res=sum/2;

        flag=0;

        dfs(0,6);

        if(flag)
            printf("Can be divided.\n\n");
        else
            printf("Can't be divided.\n\n");

    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: