您的位置:首页 > 产品设计 > UI/UE

poj 2524 Ubiquitous Religions

2014-07-17 22:16 423 查看
http://poj.org/problem?id=2524

Ubiquitous Religions

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 23221Accepted: 11440
Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound
of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The
end of input is specified by a line in which n = m = 0.
Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output
Case 1: 1
Case 2: 7

本题是一个简单的典型的并查集题目,套模板来就可以了。
这里给出两种代码
AC代码一:(这个是套的网上的模板,比较便于初学者理解)
#include <iostream>  
using namespace std;  
  
int father[50001],rank[50001];  
  
void Init(int n)  //初始化
{  
    int i;  
    for(i=1;i<=n;i++)  
    {  
        father[i]=i;  
        rank[i]=1;  
    }  
}  
  
int Find_Set(int x)  //搜素 找父节点
{  
    if(x!=father[x])  
        father[x]=Find_Set(father[x]);  
    return father[x];  
}  
  
void Union_Set(int x,int y)  //合并
{  
    x=Find_Set(x);  
    y=Find_Set(y);  
    if(x==y)return;  
    if(rank[x]>=rank[y])  
    {  
        father[y]=x;  
        rank[x]+=rank[y];  
    }else  
    {  
        father[x]=y;  
        rank[y]+=rank[x];  
    }  
}  
  
int main()  
{   
    int n,m;  
    int i,x,y,c;  
    int num=1;  
    while(1)  
    {  
        cin>>n>>m;  
        if(!n && !m)break;  
        Init(n);  
        for(i=0;i<m;i++)  
        {  
            cin>>x>>y;  
            Union_Set(x,y);  
        }  
        c=0;  
        for(i=1;i<=n;i++)  
        {  
            if(i==father[i])c++;  
        }  
        cout<<"Case "<<num<<": "<<c<<endl;  
        num++;  
    }  
    return 0;  
}


AC代码二:(这个比较简洁明了)
#include<iostream>
#include<cstring>
using namespace std;

int f[500005],v[500005];

int find(int x)//搜索
{
	return f[x] == x ? x : find(f[x]);
}

int main()
{
	int n,m,k=0;
	while(cin>>n>>m)
	{
		if(n==0 && m==0)   break;
		int x,y,i,j;
		for(i=0;i<n;i++)
		{
			f[i]=i;//初始化
			v[i]=0;
		}

		for(i=0;i<m;i++)
		{
			cin>>x>>y;
			f[find(x)]=find(y);//合并
		}

		int sum=0;
		for(i=0;i<n;i++)
		{
			if(v[i]==0 && f[i]==i)
			{
				sum++;
				v[i]=1;
			}
		}

		cout<<"Case "<<k++<<": "<<sum<<endl;
	}

	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: