您的位置:首页 > 其它

Knight Moves--广度优先搜索

2014-07-17 11:37 344 查看
Knight Moves

Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of
the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4

a1 b2

b2 c3

a1 h8

a1 h7

h8 a1

b1 c3

f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.

To get from a1 to b2 takes 4 knight moves.

To get from b2 to c3 takes 2 knight moves.

To get from a1 to h8 takes 6 knight moves.

To get from a1 to h7 takes 5 knight moves.

To get from h8 to a1 takes 6 knight moves.

To get from b1 to c3 takes 1 knight moves.

To get from f6 to f6 takes 0 knight moves.

如图所示,举个例子在d4这个位子,有8个方向

12345678
a
b**
c**
d#
e**
f**
g
h
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
int dir[8][2]={{-1,-2},{-2,-1},{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2}};
struct node
{
char c;
int a,sum;
}F,L;
int main()
{
int i;
node temp;
queue<node>Q;
while(cin>>F.c>>F.a>>L.c>>L.a!=NULL)
{
cout<<"To get from "<<F.c<<F.a<<" to "<<L.c<<L.a<<" takes ";
while(!Q.empty())Q.pop();
F.sum=0;
Q.push(F);
while(1)
{
F=Q.front();
Q.pop();
if(F.c==L.c&&F.a==L.a)
break;
for(i=0; i<8; i++)
{
temp.c=F.c+dir[i][0];
temp.a=F.a+dir[i][1];
temp.sum=F.sum+1;
if(temp.c<'a'||temp.c>'h'||temp.a<1||temp.a>8)
continue;
Q.push(temp);
}
}
cout<<F.sum<<" knight moves.\n";
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: