您的位置:首页 > 其它

hdu 2035 人见人爱A^B(快速幂入门)

2014-07-16 22:42 369 查看


人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit:
65536/32768 K (Java/Others)

Total Submission(s): 21826 Accepted Submission(s): 15201



Problem Description

求A^B的最后三位数表示的整数。

说明:A^B的含义是“A的B次方”

Input

输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。

Output

对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。

Sample Input

2 3
12 6
6789 10000
0 0


Sample Output

8
984
1


分析:
(1)求a^b的最后三位,即为a^b%1000的值,
同余基本性质:ab≡(a%m)(b%m)(mod m).
#include <iostream>
#include<stdio.h>
using namespace std;
int main()
{
int a,b;
int ans;
while (cin>>a>>b &&(a||b))
{
ans=1;
for (int i=1; i<=b; i++)
{
ans=ans*a%1000;
}
cout<<ans<<endl;
}
return 0;
}


(2)快速幂模m算法
#include <iostream>
#include<stdio.h>
using namespace std;
long long quick_mod(long long &a,long long &b,long long m)
{
long long ans=1;
while (b)
{
if(b&1)
{
ans=(ans*a)%m;
b--;
}
b/=2;
a=a*a%m;
}
return ans;
}
int main()
{
long long a,b;
long long ans;
while (cin>>a>>b &&(a||b))
{
ans=quick_mod(a, b, 1000);
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: