您的位置:首页 > 其它

hdu 1051 Wooden Sticks

2014-07-15 21:46 501 查看

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11244 Accepted Submission(s): 4627

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup
time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.

(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).



Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents
the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers
are delimited by one or more spaces.



Output
The output should contain the minimum setup time in minutes, one per line.



Sample Input
3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1




Sample Output
2
1
3




题目大意:

给n根木棍的长度和重量。根据要求求出***木棍的最短时间。建立第一个木棍需要1分钟,若是接着要***的木棍重量和长度都比此木棍长就不需要建立的时间,若是没有,则再需要建立时间。求时间最小为多少。

解题思路:

对木棍的长度和重量进行排序,以长度为首要考虑。排序完后的不一定都是下一根木棍重量和长度都大于前一根的。于是,我们对排序后的数组进行多次扫描,将可以在一次建立时间内完成的进行标记,知道木棍全部标记(设置一个外部变量来计数已扫描的元素的数量)。

例子:

5

4 9 5 2 2 1 3 5 1 4

排序完后:

1 4 2 1 3 5 4 9 5 2

进行第一次扫描:使用mark[]数组进行标记,mark[]初始化为0,红色为第一次描过的。

Stiks: (1 4) (2 1) (3 5) (4 9) (5 2)

Mark: 1 0 1 1 0

这是的setuptime为建立第一根木棍所要的时间,即1,此时扫描计数为3

接着进行第二次扫描,蓝色为第二次扫描过的结果。

Stiks: (1 4) (2 1) (3 5) (4 9) (5 2)

Mark: 1 0 1 1
0

这是的setuptime为1,此时扫描计数为5

代码如下:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#define M 10000
using namespace std;

struct node
{
	int x,y,z;
}p[M];

int cmp(node a,node b)
{
	if(a.x<b.x) return 1;
	else 
	{
		if(a.x==b.x)
		{
			if(a.y<b.y) 
				return 1;
		}
		else return 0;
	}
	
}

int main ()
{ 
	int n,m;
	int i,j;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d",&m);
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&p[i].x,&p[i].y);
			p[i].z=0;
		}
		sort(p,p+m,cmp);
		int sum=0;
		for(i=0;i<m;i++)
		{
			if(p[i].z==0)
			{
				p[i].z=1;
				sum++;
				int k=p[i].y;
				for(j=i+1;j<m;j++)
				{
					if(p[j].z==0 && p[j].y>=k)
					{
						p[j].z=1;
						k=p[j].y;
					}
				}
			}
		}	
		printf("%d\n",sum);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: