您的位置:首页 > 其它

Uva 12124 Assemble 解题报告(二分)

2014-07-15 11:48 363 查看

Problem A - Assemble

Time limit: 2 seconds

Recently your team noticed that the computer you use to practice for programming contests is not good enough anymore. Therefore, you decide to buy a new computer.
To make the ideal computer for your needs, you decide to buy separate components and assemble the computer yourself. You need to buy exactly one of each type of component.
The problem is which components to buy. As you all know, the quality of a computer is equal to the quality of its weakest component. Therefore, you want to maximize the quality of the component with the lowest quality,
while not exceeding your budget.

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:
One line with two integers: 1 ≤ n ≤ 1000, the number of available components and 1 ≤ b ≤ 1000000000, your budget.
n lines in the following format: ``type name price quality'', where type is a string with the type of the component, name is a string with the unique name of the component, price is an integer (0 ≤ price <
1000000) which represents the price of the component and quality is an integer (0 ≤ quality ≤ 1000000000) which represents the quality of the component (higher is better). The strings contain only letters, digits and underscores and have
a maximal length of 20 characters.
It will always possible to construct a computer with your budget.

Output

Per testcase:
One line with one integer: the maximal possible quality.

Sample Input

1
18 800
processor 3500_MHz 66 5
processor 4200_MHz 103 7
processor 5000_MHz 156 9
processor 6000_MHz 219 12
memory 1_GB 35 3
memory 2_GB 88 6
memory 4_GB 170 12
mainbord all_onboard 52 10
harddisk 250_GB 54 10
harddisk 500_FB 99 12
casing midi 36 10
monitor 17_inch 157 5
monitor 19_inch 175 7
monitor 20_inch 210 9
monitor 22_inch 293 12
mouse cordless_optical 18 12
mouse microsoft 30 9
keyboard office 4 10


Sample Output

9

解题报告: 二分题。二分质量,看能否在预算里配好电脑。

我个人觉得在配件里找到最便宜的、质量超过指定质量的配件直接暴力复杂度略高。当然,n比较小,也就无所谓了。

代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <string>
using namespace std;

#define ff(i, n) for(int i=0;i<(n);i++)
#define fff(i, n, m) for(int i=(n);i<=(m);i++)
#define dff(i, n, m) for(int i=(n);i<=(m);i++)
typedef long long LL;
typedef unsigned long long ULL;
void work();

int main()
{
#ifdef ACM
freopen("in.txt", "r", stdin);
#endif // ACM

work();
}

///////////////////////////////////////////

struct Node
{
int price;
int quality;
} x;

typedef vector<Node> Nodes;
typedef map<string, Nodes> Map;
typedef map<string, Nodes>::iterator It;

int n, v;

bool check(int quality, Map & c)
{
int sum=0;
for(It it=c.begin();it!=c.end();it++)
{
Nodes & nodes = it->second;

int minP = ~0U>>1;
for(int i=0;i<nodes.size();i++) if(nodes[i].quality >= quality)
minP = min(minP, nodes[i].price);
if(minP == ~0U>>1) return false;

sum += minP;
}
return sum <= v;
}

void work()
{
int T;
scanf("%d", &T);
while(T--)
{
scanf("%d%d", &n, &v);

Map c;
ff(i, n)
{
char name[20];
scanf("%s%*s%d%d", name, &x.price, &x.quality);
c[name].push_back(x);
}

int l = 0, r = 1000000000;
while(l<=r)
{
int mid = (l+r)>>1;
if(check(mid, c))
l = mid+1;
else
r = mid-1;
}

printf("%d\n", r);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  二分