您的位置:首页 > 其它

Uva 340 Master-Mind Hints

2014-07-15 10:45 369 查看
A - Master-Mind Hints

Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld
& %llu

Description

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other,Breaker, tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the lengthN
that a code must have and upon the colors that may occur in a code.

In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code.

In this problem you will be given a secret code

and a guess


, and are to determine the hint. A hint consists of a pair of numbers determined as follows.

A match is a pair (i,j),

and


, such that

. Match (i,j) is calledstrong when
i = j, and is called weak otherwise. Two matches (i,j) and (p,q) are calledindependent when
i = p if and only if j = q. A set of matches is called
independent when all of its members are pairwise independent.

Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches inM. Note that
these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n,0), then the guess is identical to the secret code.



Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the
range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess.

Following the data for the first game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single zero (when a value for N would normally be specified). The maximum
value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each
game should be prefixed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input

4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0


Sample Output

Game 1:
    (1,1)
    (2,0)
    (1,2)
    (1,2)
    (4,0)
Game 2:
    (2,4)
    (3,2)
    (5,0)
    (7,0)


题目大意:

给定一个密码串,输入待匹配串,密码串和匹配串的每个字符为1~9

位置相同且数字相等则的为强,位置不同但数字相等的为弱

输出(A,B) A为强,B为弱

#include <stdio.h>
#include <string.h>

const int N = 1000;
const int MAX = 11;
int guess
,code
,gd[MAX],cd[MAX];
int main() {
	int t,now=0;
	while(scanf("%d",&t)!=EOF,t) {
		printf("Game %d:\n",++now);
		for(int i=0;i<t;i++)
			scanf("%d",&code[i]);
		while(1) {
			memset(cd,0,sizeof(cd));
			memset(gd,0,sizeof(gd));
			int A=0,B=0;
			for(int i=0;i<t;i++)
				scanf("%d",&guess[i]);

			bool flag = true;
			for(int i=0;i<t;i++) { //判断是否含有0
				if(guess[i] != 0){
					flag=false;
					break;
				}	
			}
			if(flag ==true) //如果含有0就跳出循环
				break;

			for(int i=0;i<t;i++) {
				if(guess[i] == code[i]) //如果位置相同且数字相同则A++	
					A++;
				else { //如果位置相同,但是数字不同就把标记数组++
					gd[guess[i]]++; 
					cd[code[i]]++; 
				}
			}
			for(int i=0;i<=9;i++) { //B加上较小的标记数,因为较小的标记数肯定包含于较多的标记数之中
				if(gd[i] < cd[i]) {
					B += gd[i];
				}
				else {
					B += cd[i];	
				}
			}
			printf("    (%d,%d)\n",A,B);
		}	
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: