您的位置:首页 > 其它

uva 10161(数学)

2014-07-14 19:51 246 查看
题目:

One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in
a word, the path was like a snake.

  For example, her first 25 seconds went like this:

  ( the numbers in the grids stands for the time when she went into the grids)

 

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

  5

  

  4

  

  3

  2 

 

  1

    1        2           3        4         5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

input

Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

output

'For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

sample input

8

20

25

0

sample output

2 3

5 4

1 5
题解:找规律。。

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

int main() {
int n, x, y;
while (scanf("%d", &n) != EOF && n) {
int a = sqrt(n);
int b = sqrt(n) + 1;
if (n == (a * a)) {
if (a % 2 != 0)
printf("1 %d\n", a);
else
printf("%d 1\n", a);
continue;
}
else {
if (a % 2 != 0) {
if (n <= (a * a + b)) {
int x = n - a * a;
int y = b;
printf("%d %d\n", x, y);
continue;
}
else if (n < (b * b)) {
int x = b;
int y = b * b - n + 1;
printf("%d %d\n", x, y);
continue;
}
}
else {
if (n <= (a * a + b)) {
int y = n - a * a;
int x = b;
printf("%d %d\n", x, y);
continue;
}
else if (n < (b * b)) {
int y = b;
int x = b * b - n + 1;
printf("%d %d\n", x, y);
continue;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva 数学