您的位置:首页 > 大数据 > 人工智能

uva442-Matrix Chain Multiplication

2014-07-13 15:29 405 查看


 Matrix Chain Multiplication 
Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the
number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n ( 

 ), representing
the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"


Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print
one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))


Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

这题的解题思路类似于加减乘除运算
#include <iostream>
#include <stack>
#include <string>
#include <map>
using namespace std;

struct mat{
int row;
int column;
};
stack<char> st1;
stack<mat> st2;
map<char, int> rows, columns;
int main(void){
string s;
char c;
int r, l;
int num;

#ifndef ONLINE_JUDGE
freopen("f:\\infile.txt","r",stdin);
#endif

cin >> num;
while(num--){
cin >> c >> r >> l;
rows[c] = r;
columns[c] = l;
}

cin.ignore(10, '\n');
while(getline(cin, s)){
int flag = 0;
int mulTime = 0;
while(st2.size())
st2.pop();
for(int i = 0; i < s.size(); i++){
if(s[i] == '('){
st1.push(s[i]);
}
else if(s[i] == ')'){
mat x, y;
y = st2.top();
st2.pop();
x = st2.top();
st2.pop();
if(x.column != y.row){
cout << "error" << endl;
flag = 1;
break;
}
mat temp;
temp.row = x.row;
temp.column = y.column;
st2.push(temp);
mulTime += (x.row*x.column*y.column);
}
else{
mat temp;
temp.row = rows[s[i]];
temp.column = columns[s[i]];
st2.push(temp);
}
}
if(flag == 0)
cout << mulTime << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva