您的位置:首页 > 大数据 > 物联网

UVA_10881 - Piotr's Ants

2014-07-13 09:14 411 查看
Problem D

Piotr's Ants

Time Limit: 2 seconds

"One thing is for certain: there is no stopping them;

the ants will soon be here. And I, for one, welcome our

new insect overlords."
Kent Brockman
Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s.
When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds
from now.
Input

The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing 3 integers: L , T and n (0 <= n <=
10000). The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).
Output

For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the
same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before Tseconds, print "Fell off" for that ant. Print an empty line after each test case.
Sample InputSample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R

Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R

其实这道题目看起来有点像是POJ上面的No.1852,但是这道题目比POJ难度更大一些,蚂蚁的朝向是题目已知的,求经过T秒之后蚂蚁的状态(包括朝向和位置)。

思路:

1.首先定义一个结构体表示每只蚂蚁的位置朝向,并且记录它是第几只蚂蚁,同时结构体中用一个运算符重载来对蚂蚁按照位置进行排序

2.定义两个上面呢定义的结构体数组分别为before[]和after[],其中before[]数组表示开始的时候蚂蚁的状态,after[]表示经过了T秒之后蚂蚁的状态,最后的结果也保存在after[]数组中

3.定义一个数组order[]用来存储每只蚂蚁代表上面before[]数组和after[]数组中的哪一个,例如order[i] = j表示第i只蚂蚁存储在before[j]和after[j]中

#include<cstdio>
#include<algorithm>
using namespace std;

//定义一个结构体数组用来记录蚂蚁的状态
struct Ant{
int id;//用来记录是第几只蚂蚁
int p;//用来记录这只蚂蚁在哪个位置
int d;//用来记录这只蚂蚁的朝向,-1表示朝左,0表示正在转向,1表示朝右
bool operator < (const Ant &a) const{//结构体中的运算符重载
return p < a.p;
}
}before[10005], after[10005];

int main()
{
int ncase;
int L, T, n;
int p, d;
char ch;
int order[10005];
char Cond[][10] = {"L", "Turning", "R"};//表示蚂蚁朝向的数组
scanf("%d", &ncase);
for(int m = 1; m <= ncase; m++){
scanf("%d%d%d", &L, &T, &n);
for(int i = 0; i < n; i++){
scanf("%d %c", &p, &ch);
d = (ch == 'L' ? -1 : 1);//如果ch是L则将d的值赋为-1,否则赋为1
before[i] = Ant{i, p, d};
after[i] = Ant{0, p+T*d, d};
}//首先将数据输入到数组before[]中,并且改变数组after[]的值

sort(before, before+n);//对数组before进行排序
for(int i = 0; i < n; i++)
order[before[i].id] = i;//排好序号后得到数组order的值
sort(after, after+n);
for(int i = 0; i < n-1; i++)
if(after[i].p == after[i+1].p) after[i].d = after[i+1].d = 0;//如果两只蚂蚁在同一个点的话则表示他们正在转向

printf("Case #%d:\n", m);
for(int i = 0; i < n; i++){
int k = order[i];
if(after[k].p < 0 || after[k].p > L) printf("Fell off\n");
else printf("%d %s\n", after[k].p, Cond[after[k].d+1]);
}
printf("\n");
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: