您的位置:首页 > 其它

poj 3255 Roadblocks

2014-07-12 16:14 274 查看
此题为次短路问题,可以参考最短路问题的dijkstra算法,在这里使用了邻接表储存图,并使用优先队列优化,在dijkstra基础上开一个dis2数组储存次短路,分析次短路来源,有两种,一是dis[v]+cost[u][v],另外是dis2[v]+cost[u][v]。

Roadblocks

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7033 Accepted: 2616
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the
shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination)
is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if
two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 

Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output
450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
Source

USACO 2006 November Gold
下面贴代码啦:
/*
13064844 motefly 3255 Accepted 4868K 235MS G++ 1488B 2014-07-12 16:13:01
*/
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;
int n,r;
typedef pair<int ,int > P;
struct edge
{
int from,to,cost;
};

const int INF=0x3f3f3f3f;
const int MAXN=5000+10;

vector<edge> G[MAXN];
int dis[MAXN];
int dis2[MAXN];

void solve()
{
priority_queue<P,vector<P>,greater<P> > que;
memset(dis,INF,sizeof(dis));
memset(dis2,INF,sizeof(dis2));
dis[0]=0;
que.push(P(0,0));
while(!que.empty())
{
P p=que.top();
que.pop();
int v=p.second, d=p.first;
if(dis2[v]<d)
continue;
for(int i=0;i<G[v].size();i++)
{
edge & e=G[v][i];
int d2=d+e.cost;
if(dis[e.to]>d2)
{
swap(dis[e.to],d2);
que.push(P(dis[e.to],e.to));
}
if(dis2[e.to]>d2&&dis[e.to]<d2)
{
dis2[e.to]=d2;
que.push(P(dis2[e.to],e.to));
}
}
}
printf("%d\n",dis2[n-1]);
}

void init()
{
scanf("%d%d",&n,&r);
for(int i=0;i<r;i++)
{
int f,t,c;
scanf("%d%d%d",&f,&t,&c);
edge e;
e.from=t-1;
e.to=f-1;
e.cost=c;
G[t-1].push_back(e);
e.from=f-1;
e.to=t-1;
e.cost=c;
G[f-1].push_back(e);
}
}

int main()
{
init();
solve();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息