您的位置:首页 > 其它

poj 2255 Tree Recovery(求后序遍历,二叉树)

2014-07-11 18:00 302 查看
转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

题目链接:http://poj.org/problem?id=2255

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF
and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD

Sample Output
ACBFGED
CDAB


题意:给出前序和中序遍历,求后续遍历;

思路,找到根,找到左子树,找到右子树

代码一如下:

#include <cstdio>
#include <cstring>
int count;
char a[47],b[47];

void find(int start, int end)
{
	int i;
	if(start > end)
		return;
	char root = a[count++];
	for(i = start; i <= end; i++)
	{
		if(b[i] == root)
		{
			break;
		}
	}
	find(start,i-1);
	find(i+1,end);
	printf("%c",root);
}
int main()
{
	while(scanf("%s%s",a,b)!=EOF)
	{
		count = 0;
		int len = strlen(b);
		find(0,len-1);
		printf("\n");
	}
	return 0;
}


代码二:

#include <stdio.h>
#include <string.h>
#define N 27
char pre
,in
;
int id
;
void print(int a,int b,int c,int d)
{
	int i=id[pre[a]-'A'];
	int j=i-c;
	int k=d-i;
	if(j)   print(a+1,a+j,c,i-1);
	if(k)   print(a+j+1,b,i+1,d);
	printf("%c",pre[a]);
}
int main()
{
	while(~scanf("%s%s",pre,in))
	{
		for(int i=0;in[i];i++)  
			id[in[i]-'A']=i;
		int len=strlen(in);
		print(0,len-1,0,len-1);
		puts("");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: