您的位置:首页 > 其它

Palindrome - POJ 1159 dp

2014-07-11 14:30 351 查看
Palindrome

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 51741Accepted: 17811
Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
Sample Input
5
Ab3bd

Sample Output
2


题意:问最少需要补几个字符,使得其成为一个回文串。

思路:最简单的dp了,具体见代码吧。一开始还在考虑是挂在dp里,还是挂在水题里,想了想,简单的dp也是dp,别拿村长不当干部。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
short dp[5010][5010];
char s[5010];
int main()
{ int n,i,j,k;
  scanf("%d",&n);
  scanf("%s",s);
  for(i=n;i>=1;i--)
   for(j=i+1;j<=n;j++)
   { dp[i][j]=min(dp[i+1][j]+1,dp[i][j-1]+1);
     if(s[i-1]==s[j-1])
      dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
    //printf("%d %d %d\n",i,j,dp[i][j]);
   }
  printf("%d\n",dp[1]
);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: