您的位置:首页 > 其它

Parencodings - POJ 1068 水题

2014-07-11 13:40 302 查看
Parencodings

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 19336Accepted: 11665
Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:

q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed
string. It contains n positive integers, separated with blanks, representing the P-sequence.
Outputb the output line should contain n integers describing the W-sequence of the string corresponding to its given
P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


题意:第一种是表示方法是第几个)左边有多少(,第二种表示方法是第几个)和与其对应的(中间的(的数量。

思路:先还原数据,在求括号的对应。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int num[500],sum[500],f[500],p[500],q[500];
int main()
{ int t,n,i,j,k,pos,pos2;
  scanf("%d",&t);
  while(t--)
  { scanf("%d",&n);
    pos=0;
    pos2=0;
    for(i=1;i<=n;i++)
    { scanf("%d",&num[i]);
      for(j=num[i-1];j<num[i];j++)
      { f[++pos]=1;
        p[++pos2]=pos;
      }
      f[++pos]=2;
      q[pos]=p[pos2--];
    }
    for(i=1;i<=2*n;i++)
     if(f[i]==1)
      sum[i]=sum[i-1]+1;
     else
      sum[i]=sum[i-1];
     for(i=1;i<=2*n-1;i++)
      if(f[i]==2)
       printf("%d ",sum[i]-sum[q[i]-1]);
    printf("%d\n",sum[2*n]-sum[q[2*n]-1]);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: