您的位置:首页 > 其它

UVA-133 双向链表模拟题

2014-07-10 20:31 239 查看


 The Dole Queue 
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing
inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts
from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person
and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three
numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0


Sample output


 4 

 8, 

 9 

 5, 

 3 

 1, 

 2 

 6, 

 10, 

 7
where 

 represents a space.
#include <iostream>
#include <fstream>
using namespace std;
struct Node{
int n;
Node *front,*next;
};
int main()
{
//ifstream fin("ha.txt");
int n,count_shun,count_ni,temp_shun,temp_ni;
while(cin>>n>>count_ni>>count_shun&&(n||count_ni||count_shun))
{
//poccess count_shun, count_ni

//build a Node list
Node *head,*pre,*p,*p_shun,*p_ni;
head=new Node;
head->n=1;
p=head;
for(int i=2;i<=n;i++)
{
p->next=new Node;
pre=p;
p=p->next;
p->n=i;
p->front=pre;
}
//p point to n now;
head->front =p;
p->next=head;
p=head->front;
//build ok
p_ni=head;
p_shun=head->front;
//ready? go
while(n>=1)
{
if(count_shun%n==0)temp_shun=n;
else{temp_shun=count_shun%n;}
if(count_ni%n==0)temp_ni=n;
else{temp_ni=count_ni%n;}
//cout<<temp_ni<<" "<<temp_shun<<endl<<endl;
for(int i=1;i<temp_shun;i++)p_shun=p_shun->front;
for(int i=1;i<temp_ni;i++)p_ni=p_ni->next;
if(p_ni==p_shun)
{
p=p_ni->next;
pre=p_ni->front;
pre->next=p;
p->front=pre;
n--;
if(p_ni->n>=10){cout<<" ";}
else{cout<<" ";}
cout<<p_ni->n;
if(n!=0)cout<<",";
delete p_ni;
p_ni=p;
p_shun=pre;
}
else
{
//n-=2;
n-=2;
//delete p_ni
if(p_ni->n>=10){cout<<" ";}
else{cout<<" ";}
cout<<p_ni->n;
p=p_ni->next;
pre=p_ni->front;
pre->next=p;
p->front=pre;
delete p_ni;
p_ni=p;
if(p_shun==p_ni)p_ni=p_ni->next;
//delete p_shun
if(p_shun->n>=10){cout<<" ";}
else{cout<<" ";}
cout<<p_shun->n;
if(n!=0)cout<<",";
p=p_shun->next;
pre=p_shun->front;
pre->next=p;
p->front=pre;
delete p_shun;
p_shun=pre;
}
}
cout<<endl;
}
}



 The Dole Queue 
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing
inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts
from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person
and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three
numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise
official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0


Sample output


 4 

 8, 

 9 

 5, 

 3 

 1, 

 2 

 6, 

 10, 

 7
where 

 represents a space.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: