您的位置:首页 > 其它

poj 1562 Oil Deposits 简单dfs

2014-07-10 18:48 459 查看
Oil Deposits

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 12228Accepted: 6615
Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each
plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous
pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this
are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

题意是n*m的油田 @代表有油上下左右对角相邻都代表联通(即为一个矿) 输出矿的个数

人生第一题算法题  代码如下

#include<stdio.h>
#include<string.h>
int dx[10]={-1,0,1,-1,1,-1,0,1};
int dy[10]={-1,-1,-1,0,0,1,1,1};//方向
int n,m;
bool map[110][110];
void dfs(int x,int y)
{
    int nx,ny,i;
    map[x][y]=0;
    for(i=0;i<8;i++)
    {
        nx=x+dx[i];
        ny=y+dy[i];
        if(nx>n||ny>m||nx<1||ny<1)
            continue;
        if(map[nx][ny]==1)
            dfs(nx,ny);
    }
}
int main()
{
    int count,i,j;
    char a;
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
    {
        memset(map,0,sizeof(map));
        count=0;
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
        {
            scanf(" %c",&a);
            if(a=='@')
                map[i][j]=1;
        }
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
        {
            if(map[i][j])
            {
                dfs(i,j);
            count++;
            }
        }
        printf("%d\n",count);
    }
    return 0;
}


最基础的dfs 想了整整一下午
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: