您的位置:首页 > 其它

2095 find your present (2)

2014-07-10 15:48 204 查看


find your present (2)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/1024 K (Java/Others)

Total Submission(s): 15011 Accepted Submission(s): 5685



Problem Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number
will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is
the number that different from all the others.

Input

The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5
1 1 3 2 2
3
1 2 1
0


Sample Output

3
2


//思路:因为重复的号码都是复数的,所以用异或运算符即可得出只出现一次的那个号码

#include<stdio.h>
int main()
{
int n,m,num;
while(scanf("%d",&n),n)
{
num=0;
while(n--)
{
scanf("%d",&m);
num^=m;
}
printf("%d\n",num);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: