您的位置:首页 > 其它

POJ 1573 Robot Motion (DFS)

2014-07-09 16:04 399 查看
Robot Motion
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 10285Accepted: 5010
Description



A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number
of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at
most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions
on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)"
whether or not the number before it is 1.
Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source
Mid-Central USA 1999

#include <iostream>
#include <algorithm>
#include <math.h>
#include <string.h>
using namespace std; 
char mat[12][12];
int vis[12][12],X[12][12];
void T (int x,int y,int cur)
{
   printf("%d step(s) before a loop of %d step(s)\n",X[x][y],cur-X[x][y]);
}

void DFS(int x,int y,int cur)
{   vis[x][y]++;
	if(mat[x][y]=='0')
	{ 
       printf("%d step(s) to exit\n",cur);
	   return;
	} 
	else
		if(vis[x][y]==2)
		{
          T(x,y,cur);
		}
	if(vis[x][y]==1)
	{ 
      X[x][y]=cur;
	  if(mat[x][y]=='N')
	  { 
		x--;
	  } 
	  else if(mat[x][y]=='W')
	  { 	
		y--;
	  } 
	  else if(mat[x][y]=='S')
	  { 	
		x++;
	  } 
	  else if(mat[x][y]=='E')
	  { 	
		y++;          
	  } 
	   
	   DFS(x,y,cur+1);
	} 
} 
int main()
{
int n,m,t,i,j,y;
  while(scanf("%d%d%d",&n,&m,&y)!=EOF)
  { getchar();
  if(n==0&&m==0&&y==0) break;
   memset(vis,0,sizeof(vis));
   memset(mat,'0',sizeof(mat));
    for(i=1;i<=n;i++)
	{
		for(j=1;j<=m;j++)
			scanf("%c",&mat[i][j]);
			getchar();
	}
	DFS(1,y,0);
  }
  return 0;
}

不知道模拟法是什么,所以还是按回溯的思想做的,开始应为先走后标记多跑了一圈,看了别人的改成先标记后走,

还是围一圈墙不考虑边界。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: