您的位置:首页 > 其它

POJ 1753 Flip Game (DFS)

2014-07-08 14:49 246 查看
Flip Game

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 14504Accepted: 6218
Description
Flip game is played on a rectangular 4x4 fieldwith two-sided pieces placed on each of its 16 squares. One side ofeach piece is white and the other one is black and each piece islying either it's black or white side up. Each round
you flip 3 to5 pieces, thus changing the color of their upper side from black towhite and vice versa. The pieces to be flipped are chosen everyround according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left,to the right, to the top, and to the bottom of the chosen piece (ifthere are any).


Consider the following position as anexample:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotespieces lying their white side up. If we choose to flip the 1stpiece from the 3rd row (this choice is shown at the picture), thenthe field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up orall pieces black side up. You are to write a program that willsearch for the minimum number of rounds needed to achieve thisgoal.

Input
The input consists of 4 lines with 4 characters"w" or "b" each that denote game field position.
Output
Write to the output file a single integer number -the minimum number of rounds needed to achieve the goal of the gamefrom the given position. If the goal is initially achieved, thenwrite 0. If it's impossible to achieve the goal,
then write theword "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4

Source
NortheasternEurope 2000



#include<stdio.h>
int map[4][4],step,flag=0;
void turn(int i,int j)//转换
{
map[i][j]=!map[i][j];
if(i>0)
map[i-1][j]=!map[i-1][j];
if(i<3)
map[i+1][j]=!map[i+1][j];
if(j>0)
map[i][j-1]=!map[i][j-1];
if(j<3)
map[i][j+1]=!map[i][j+1];
}
int range()//判定表格是否全部一样
{
int i,j;
for(i=0;i<4;i++)
for(j=0;j<4;j++)
if(map[i][j]!=map[0][0])
return 0;
return 1;
}
int DFS(int i,int j,int dp)//深搜
{
if(dp==step){
flag=range();
return 0;
}
if(flag||i==4)return 1;
turn(i,j);
if(j<3)DFS(i,j+1,dp+1); //从这里进下一层就是翻了i行j列的棋子,或者是下一行第一个棋子。
else DFS(i+1,0,dp+1);   
turn(i,j);
if(j<3)DFS(i,j+1,dp);   //从这里进下一层就是没翻i行j列或者下一行第一个棋子。就是判定这个子树没有可能存在的解,处死。
else DFS(i+1,0,dp);
return 0;
}
int main()
{
int i,j;
char a;
for(i=0;i<4;i++)
{
for(j=0;j<4;j++)
{
scanf("%c",&a);
if(a=='b')map[i][j]=0;
else map[i][j]=1;
}
getchar();
}
for(step=0;step<=16;step++)
{
flag=0;
DFS(0,0,0);
if(flag)break;
}
if(flag)printf("%d\n",step);
else printf("Impossible\n");
return 0;
}

其实代码是看别人的解题报告才做出来的,我的那个用围墙最后也可以过。

一直以为应该用广搜来做,这个代码,我开始在怀疑是不是找到一个解就输出而不是最佳解。

因为没看见step在for循环里面变值,所以开始一直头痛。

这个代码的意思是翻一次的情况考虑完再考虑翻两次的情况,依次类推直到step=16.

所以这道题的关键就在于最多翻16次这个问题上了,没明白,所以不解释。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: